Tags give the ability to mark specific points in history as being important
This project is mirrored from https://github.com/SickChill/SickChill.git. Pull mirroring updated .
  • 2022.10.13
    Release version 2022.10.13
    Merge branch 'develop'
    Update poetry (python) and yarn (npm) dependencies
    Update upgrade_dependencies.yml
    Update upgrade_dependencies.yml
    style(maint): add pre-commit and commitizen (#8244) (#8248)
  • 2022.10.8
    a185445b · Release version 2022.10.8 ·
    Release version 2022.10.8
    Missed pipe extension
    Start adding a workflow and tool to properly bump date-versioning-string
    Update poetry (python) and yarn (npm) dependencies
    Update README.md
    Bump snok/install-poetry from 1.3.1 to 1.3.2 (#8240)
    Test docker image before push (#8243)
    Bump eslint-plugin-unicorn from 44.0.1 to 44.0.2 (#8241)
    Bump snyk from 1.1024.0 to 1.1025.0 (#8242)
    Update poetry (python) and yarn (npm) dependencies
    Clean up dockerfile using linter hints, add links to pyproject to be shown on pypi
    Switch from actions/cache to buildx built-in cache for actions and actions/setup-python built-in caching. Fix typo in linux.s390x => linux/s390x Set base python version for experimental testing to 3.10, and 3.11-dev to 3.11-rc2 Re-enable fail-fast and disable continue-on-error Remove unnecessary code and neaten up Dockerfile
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Drop python_version constraint for cryptography
    Update poetry (python) and yarn (npm) dependencies
    Try to make sure rustc stays on the path
    Last try for s390x and ppc64le
    Revert buildx testing commits to working state, disable s390x and ppc64le
    Update pythonpackage.yml
    Update pythonpackage.yml
    Update Dockerfile
    Bump eslint-plugin-unicorn from 43.0.2 to 44.0.0 (#8228)
    Bump styfle/cancel-workflow-action from 0.10.0 to 0.10.1 (#8227)
    Update Dockerfile
    Update Dockerfile
    --security flag is unknown
    See if actions allows us to set insecure-entitlements = [ "network.host", "security.insecure" ]
    Update poetry (python) and yarn (npm) dependencies
    Update pyproject.toml
    Update pythonpackage.yml
    Update pythonpackage.yml
    Update pythonpackage.yml
    Pin stevedore to 3.4.1 for python 3.7. Project dropped support for python 3.7.
    Update Dockerfile
    Update Dockerfile
    Update pyproject.toml
    Update pyproject.toml
    Update pyproject.toml
    Update pyproject.toml
    Update pyproject.toml
    Update pyproject.toml
    Update pyproject.toml
    Delete .python-version (#8225)
    Update pythonpackage.yml
    Update pyproject.toml
    Upload arm/v7 wheels as artifacts.
    Drop ppc64le and s390x for now.
    Try another way to find the built wheel in the dockerfile
    Drop linux/386
    Idk why this isn't working, is it some caching issue?
    Remove the downloaded get-pip.py
    What is going on
    Try Poetry 1.2.1
    Change workflow a bit and update pip inside
    Pull ParserBeautifulSoup from subliminal into our code, pin cryptography to < 35.0.0
    Set piwheels extra-index-url in dockerfile, hopefully I dont need to split them up again. Set PYTHONBUFFERED, so we can see python error output in terminal during build, insted of only in the container log download
    Update poetry (python) and yarn (npm) dependencies
    Make sure curl uses https
    Add rustup back to Dockerfile in builder stage
    Try to fix docker build and arm32 builds
    Update Dockerfile
    another fix for str.format missing var name (#8224)
    anime parser (#8222)
    Update poetry (python) and yarn (npm) dependencies
    Default item_size so torrent RSS feeds work again (#8219)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update debian-ubuntu-install.sh
    Fix dockerfile syntax error
    Update Dockerfile
  • 2022.9.28
    78b659be · Release version 2022.9.28 ·
    Release version 2022.9.28
    Merge branch 'develop'
    Make sure to install dev dependencies when running tests
  • 2022.9.26
    e6d567dc · Release version 2022.9.26 ·
    Release version 2022.9.26
    Update poetry (python) and yarn (npm) dependencies
    Fix: translatable stringn error for global proxy
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update Dockerfile.rpi
    Update Dockerfile.pip
    Update Dockerfile
    Update Dockerfile.rpi
    Update Dockerfile
    Update Dockerfile.rpi
    Update Dockerfile
    Update test_pip.py
    Update test_pip.py
    Switch docker builds to use pip entirely, from source, and add arm6/7 to docker builds to see if they build now
    Update poetry (python) and yarn (npm) dependencies
    Bump actions/stale from 5 to 6 (#8194)
    Bump snyk from 1.1009.0 to 1.1011.0 (#8195)
  • 2022.9.22
    37535f72 · Release version 2022.9.22 ·
    Release version 2022.9.22
    Code cleanup/tv (#8189)
    Fix ui timeout searching indexers\n 8161#issuecomment-1250823193
    Update poetry (python) and yarn (npm) dependencies
    Bump snyk from 1.1008.0 to 1.1009.0 (#8190)
    Update poetry (python) and yarn (npm) dependencies
    Bump snyk from 1.1006.0 to 1.1007.0 (#8188)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    SickChill with more rage removal (#8117)
    Add ability to change logs folder (#8161)
    Update pip.py (#8182)
  • 2022.9.17
    e0bb8293 · Release version 2022.9.17 ·
    Release version 2022.9.17
    Fixes #8169
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
  • 2022.9.14
    b20f7b31 · Release version 2022.9.14 ·
    Release version 2022.9.14
    Fix error in Gruntfile.js for release
    Allow feeds to not have seeder/leecher information for example with rsstorrents.
    Update poetry (python) and yarn (npm) dependencies
    Remove git and source updating from the self updater, and remove code that switches branches and compares commits. Pip updates are all that is supported (for now) (#8162)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Bump snyk from 1.997.0 to 1.998.0 (#8145)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Tests and fixes (#8124)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
     Use rustup installer --profile minimal to avoid doc install (#8131)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
  • 2022.8.30
    b2b09e37 · Release version 2022.8.30 ·
    Release version 2022.8.30
    Merge branch 'develop'
    ffi doesnt support pathlib yet in pypy
    Path.unlink missing_ok parameter was not added until 3.8 From docs: "Changed in python version 3.8: The missing_ok parameter was added."
    Some reason this fails on python3.7, lets be explicit
    Fix another typo
    Fix typo in newnewznab.py
    Fix order of setting verify mode in make_context, we have to set check_hostname before setting the verify_mode Fix testing of created https/ssl certs, especially for pypy
    Try to fix ssl key and cert generation on pypy (and possibly some regulat cpython installs)
  • 2022.8.29
    d4591784 · Release version 2022.8.29 ·
    Release version 2022.8.29
    Merge branch 'develop'
    Undo the mess with seconds in the version string, breaking release strategy
    Release version 2022.8.22.74751
  • 2022.8.22
    db4d954a · Release version 2022.8.22 ·
    Release version 2022.8.22
    Do not test providers on normal test runs, because pytest-vcr is broken and causes github actions to take hours
    Update poetry (python) and yarn (npm) dependencies
    Update parser.py (#8098)
    Update helpers.py
    Update calendar.py (#8097)
    Lime torrent BeautifulSoup call (#8080)
    chg: Fix case sensitivity supportedParams property for newznab (#8087)
    Update types-setuptools requirement from ^63.2.2 to ^65.1.0 (#8091)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update processTV.py (#8085)
    Fix file.extension double dot (#8079)
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    Update poetry (python) and yarn (npm) dependencies
    I wish there was a better way to test workflows -.-
    Try to fix build linting
  • 2022.8.22.74751
    db4d954a · Release version 2022.8.22 ·
  • 2022.8.15
    a3695388 · Release version 2022.8.15 ·
    Release version 2022.8.15
    Merge branch 'develop'
    Update bs4_parser.py
  • 2022.8.14
    6f51cd4a · Release version 2022.8.14 ·
    Release version 2022.8.14
    Fix regex matching poetry output in gruntfile
    Missing stdout to poetry version setting
    Fail if poetry version bump seemed to fail
    Fix another error in grunt, getMonth starts with month 0
    Match version.py to pyproject
    Match version.py to pyproject
    Fix typo on release script
  • 2022.7.0
    d3467f33 · Release version 2022.7.0 ·
    Release version 2022.7.0
    Merge branch 'develop'
    Fix downloads column sorting on simple, banner, and small poster layouts. Fixes #8019
    Fix error in log line that broke subtitles support Fixes #8026
    Pin bandit to 1.7.2 to avoid a bug, remove poetry.lock again
    Add pypy and 3.11 beta builds to experimental tests
    Fix typo
    Add python 3.11 to tests
    Add 3.6 as an experimental build so we know when it stop working
    Drop python3.6 from pyproject, as support is no longer provided. Should contiue to run on it for awhile though with some tweaking
    Fix build
    Release 2022.07.20
  • 2022.07.20
    a1cf98ae · Merge branch 'develop' ·
    Merge branch 'develop'
    Make sure VIRTUAL_ENV is set when we restart into a virtualenv
    Remove poetry.lock
    Add updated pyproject.toml to master
    Add back poetry.lock, update yarn.lock, and check for VIRTUAL_ENV environment variable to prevent race condition
    Update dependabot.yml
    Bump grunt from 1.4.1 to 1.5.2 (#7948)
    Bump minimist from 1.2.5 to 1.2.6 (#7940)
    Fix identifier for license in pyproject and fix LICENSE.md to include the full license
  • 2022.02.20
    a72a4a42 · Release 2022.02.22 ·
    Release 2022.02.22 Fix curly braces in request formatter, Fixes #7886
    Update poetry (python) and yarn (npm) dependencies
    Update upgrade_dependencies.yml
    Update upgrade_dependencies.yml
    Bump qbittorrent-api from 2022.1.27 to 2022.2.28 (#7878)
    Bump webpack from 5.69.0 to 5.69.1 (#7879)
    Bump grunt-contrib-jshint from 3.1.1 to 3.2.0 (#7880)
    Bump snyk from 1.854.0 to 1.855.0 (#7881)
  • 2022.02.17-3
    6175f4c7 · Again ·
    Again
  • 2022.02.17-2
    Bugfix error with undefined variable 2022.02.17-2
    Merge branch 'develop'
    Squashed commit of the following:
  • 2022.02.17-1
    ef0c2f29 · Merge branch 'develop' ·
    Merge branch 'develop'
  • 2022.02.17
    d19b6f84 · Merge branch 'develop' ·
    Merge branch 'develop'
    Merge branch 'develop'